Terminale ES 2016-2017
Kartable
Terminale ES 2016-2017

Ecrire un algorithme qui encadre la solution de l'équation f(x)=0

Lorsqu'une fonction f est continue et strictement monotone sur un intervalle [a;b], avec f(a) et f(b) de signes contraires, l'équation f(x)=0 admet une unique solution α appartenant à [a;b].
Il est possible de déterminer un encadrement de α à l'aide d'un algorithme. Ce dernier pourra éventuellement ensuite être traduit en programme dans une calculatrice par exemple.

On considère une fonction f définie, continue et strictement monotone sur [a;b]. Ecrire un algorithme permettant d'encadrer la solution de l'équation f(x)=0 sur un intervalle [a;b].

Etape 1

Définir les variables à utiliser

Quatre variables réelles sont nécessaires pour faire fonctionner cet algorithme :

  • La borne inférieure a de l'intervalle sur lequel on va chercher la solution de l'équation
  • La borne supérieure b de ce même intervalle
  • Le milieu m de a et b qui va tendre vers la solution α de l'équation
  • La précision p de l'encadrement de la solution

p : réel
a : réel
b : réel
m : réel

Etape 2

Définir les informations à entrer par l'utilisateur

On indique à l'utilisateur qu'il doit entrer les valeurs des bornes inférieure a et supérieure b ainsi que de la précision p qu'il souhaite obtenir.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Etape 3

Ecrire les étapes de calcul

Afin de déterminer en encadrement de la solution f(x)=0, on procède par dichotomie. On détermine le centre m de l'intervalle [a;b]

  • Si f(a) et f(m) sont de signes contraires, on pose a=m
  • Sinon, on pose b=m

On répète autant de fois que nécessaire cette étape jusqu'à ce que ba<p.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que (ba>p)

m prend la valeur a+b2

Si f(m)×f(a)>0 alors a prend la valeur m.
Sinon b prend la valeur m.
Fin Si

Fin Tant que

Etape 4

Ecrire les étapes de calcul

On retourne à l'utilisateur l'encadrement recherché.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que (ba>p)

m prend la valeur a+b2

Si f(m)×f(a)>0 alors b prend la valeur m.
Sinon a prend la valeur m.
Fin Si

Fin Tant que

Afficher a
Afficher "<α<"
Afficher b

Si l'on cherche à écrire un algorithme qui encadre, dans le cas d'une fonction strictement monotone sur son intervalle, la solution α de l'équation f(x)=k, il suffit de transformer l'équation en f(x)k=0 et d'utiliser l'algorithme ci-dessus avec la fonction xf(x)k.

pub

Demandez à vos parents de vous abonner

Vous ne possédez pas de carte de crédit et vous voulez vous abonner à Kartable.

Vous pouvez choisir d'envoyer un SMS ou un email à vos parents grâce au champ ci-dessous. Ils recevront un récapitulatif de nos offres et pourront effectuer l'abonnement à votre place directement sur notre site.

J'ai une carte de crédit

Vous utilisez un navigateur non compatible avec notre application. Nous vous conseillons de choisir un autre navigateur pour une expérience optimale.