Ecrire un algorithme qui encadre la solution de l'équation f(x)=0Méthode

Lorsqu'une fonction f est continue et strictement monotone sur un intervalle \left[ a;b \right], avec f\left(a\right) et f\left(b\right) de signes contraires, l'équation f\left(x\right) = 0 admet une unique solution \alpha appartenant à \left[ a;b \right].
Il est possible de déterminer un encadrement de \alpha à l'aide d'un algorithme. Ce dernier pourra éventuellement ensuite être traduit en programme dans une calculatrice par exemple.

On considère une fonction f définie, continue et strictement monotone sur \left[ a;b \right]. Ecrire un algorithme permettant d'encadrer la solution de l'équation f\left(x\right) = 0 sur un intervalle \left[ a;b \right].

Etape 1

Définir les variables à utiliser

Quatre variables réelles sont nécessaires pour faire fonctionner cet algorithme :

  • La borne inférieure a de l'intervalle sur lequel on va chercher la solution de l'équation
  • La borne supérieure b de ce même intervalle
  • Le milieu m de a et b qui va tendre vers la solution \alpha de l'équation
  • La précision p de l'encadrement de la solution

p : réel
a : réel
b : réel
m : réel

Etape 2

Définir les informations à entrer par l'utilisateur

On indique à l'utilisateur qu'il doit entrer les valeurs des bornes inférieure a et supérieure b ainsi que de la précision p qu'il souhaite obtenir.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Etape 3

Ecrire les étapes de calcul

Afin de déterminer en encadrement de la solution f\left(x\right) = 0, on procède par dichotomie. On détermine le centre m de l'intervalle \left[ a;b\right]

  • Si f\left(a\right) et f\left(m\right) sont de signes contraires, on pose a=m
  • Sinon, on pose b= m

On répète autant de fois que nécessaire cette étape jusqu'à ce que b-a \lt p.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que \left(b-a \gt p\right)

m prend la valeur \dfrac{a+b}{2}

Si f\left(m\right) \times f\left(a\right) \gt 0 alors a prend la valeur m.
Sinon b prend la valeur m.
Fin Si

Fin Tant que

Etape 4

Ecrire les étapes de calcul

On retourne à l'utilisateur l'encadrement recherché.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que \left(b-a \gt p\right)

m prend la valeur \dfrac{a+b}{2}

Si f\left(m\right) \times f\left(a\right) \gt 0 alors b prend la valeur m.
Sinon a prend la valeur m.
Fin Si

Fin Tant que

Afficher a
Afficher " \;\lt \alpha \lt \;"
Afficher b

Si l'on cherche à écrire un algorithme qui encadre, dans le cas d'une fonction strictement monotone sur son intervalle, la solution \alpha de l'équation f\left(x\right)=k, il suffit de transformer l'équation en f\left(x\right)-k=0 et d'utiliser l'algorithme ci-dessus avec la fonction x\longmapsto f\left(x\right)-k.