Ecrire un algorithme qui encadre la solution de l'équation f(x)=0Méthode

Lorsqu'une fonction f est continue et strictement monotone sur un intervalle \left[ a;b \right], avec f\left(a\right) et f\left(b\right) de signes contraires, l'équation f\left(x\right) = 0 admet une unique solution \alpha appartenant à \left[ a;b \right].
Il est possible de déterminer un encadrement de \alpha à l'aide d'un algorithme. Ce dernier pourra éventuellement ensuite être traduit en programme dans une calculatrice par exemple.

On considère une fonction f définie, continue et strictement monotone sur \left[ a;b \right]. Ecrire un algorithme permettant d'encadrer la solution de l'équation f\left(x\right) = 0 sur un intervalle \left[ a;b \right].

Etape 1

Définir les variables à utiliser

Quatre variables réelles sont nécessaires pour faire fonctionner cet algorithme :

  • La borne inférieure a de l'intervalle sur lequel on va chercher la solution de l'équation
  • La borne supérieure b de ce même intervalle
  • Le milieu m de a et b qui va tendre vers la solution \alpha de l'équation
  • La précision p de l'encadrement de la solution

p : réel
a : réel
b : réel
m : réel

Etape 2

Définir les informations à entrer par l'utilisateur

On indique à l'utilisateur qu'il doit entrer les valeurs des bornes inférieure a et supérieure b ainsi que de la précision p qu'il souhaite obtenir.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Etape 3

Ecrire les étapes de calcul

Afin de déterminer en encadrement de la solution f\left(x\right) = 0, on procède par dichotomie. On détermine le centre m de l'intervalle \left[ a;b\right]

  • Si f\left(a\right) et f\left(m\right) sont de signes contraires, on pose a=m
  • Sinon, on pose b= m

On répète autant de fois que nécessaire cette étape jusqu'à ce que b-a \lt p.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que \left(b-a \gt p\right)

m prend la valeur \dfrac{a+b}{2}

Si f\left(m\right) \times f\left(a\right) \gt 0 alors a prend la valeur m.
Sinon b prend la valeur m.
Fin Si

Fin Tant que

Etape 4

Ecrire les étapes de calcul

On retourne à l'utilisateur l'encadrement recherché.

p : réel
a : réel
b : réel
m : réel

Saisir a
Saisir b
Saisir p

Tant que \left(b-a \gt p\right)

m prend la valeur \dfrac{a+b}{2}

Si f\left(m\right) \times f\left(a\right) \gt 0 alors b prend la valeur m.
Sinon a prend la valeur m.
Fin Si

Fin Tant que

Afficher a
Afficher " \;\lt \alpha \lt \;"
Afficher b

Si l'on cherche à écrire un algorithme qui encadre, dans le cas d'une fonction strictement monotone sur son intervalle, la solution \alpha de l'équation f\left(x\right)=k, il suffit de transformer l'équation en f\left(x\right)-k=0 et d'utiliser l'algorithme ci-dessus avec la fonction x\longmapsto f\left(x\right)-k.

Questions fréquentes

Quelles sont les matières disponibles sur Kartable ?

Sur Kartable, l'élève accède à toutes les matières principales de la primaire au lycée, y compris pour les spécialités et les options. Mathématiques, physique-chimie, SVT, sciences, français, littérature, histoire, géographie, enseignement moral et civique, SES, philosophie, anglais, allemand et espagnol.
Inscrivez-vous

Les cours sont-ils conformes aux programmes officiels de l'Education nationale ?

L'intégralité des cours sur Kartable est rédigée par des professeurs de l'Éducation nationale et est conforme au programme en vigueur, incluant la réforme du lycée de l'année 2019-2020.
Choisissez votre formule

L'élève peut-il accéder à tous les niveaux ?

Sur Kartable, l'élève peut accéder à toutes les matières dans tous les niveaux de son choix. Ainsi, il peut revenir sur les notions fondamentales qu'il n'aurait pas comprises les années précédentes et se perfectionner.
Plus d'info

Kartable est-il gratuit ?

L'inscription gratuite donne accès à 10 contenus (cours, exercices, fiches ou quiz). Pour débloquer l'accès illimité aux contenus, aux corrections d'exercices, mode hors-ligne et téléchargement en PDF, il faut souscrire à l'offre Kartable Premium.
Plus d'info

Qui rédige les cours de Kartable ?

L'intégralité des contenus disponibles sur Kartable est conçue par notre équipe pédagogique, composée de près de 200 enseignants de l'Éducation nationale que nous avons sélectionnés.
Afficher plus

Qu'est ce que le service Prof en ligne ?

L'option Prof en ligne est un service de chat en ligne entre élèves et professeurs. Notre Prof en ligne répond à toutes les questions sur les cours, exercices, méthodologie et aide au devoirs, pour toutes les classes et dans toutes les matières. Le service est ouvert du lundi au vendredi de 16h à 19h pour les membres ayant souscrit à l'option.
Choisissez votre formule